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File Menu Commands
Choose the command you want help on.
Open Command
Close Command
Save Command
Save As Command
Exit Commands
File Names



Open Command
Opens 16-color bitmaps (.DIB or .BMP), metafiles (.WMF), or hypergraphics (.SHG).
When you open an image file, Hotspot Editor places the graphic in a new window. Other 
graphics that are open remain displayed in their own windows.
See Also
Opening Image Files and Hypergraphics



Close Command
Closes the currently selected document window. If the hypergraphic is unsaved, Hotspot 
Editor lets you save it before closing the window.



Save Command
Saves the current hypergraphic (the one displayed in the active window). Hotspot Editor 
displays a warning if you are overwriting the original hypergraphic.
When you choose Save, the hypergraphic remains open so you can continue working on it.
See Also
Saving a Hypergraphic
Save As Command



Save As Command
Saves a hypergraphic.
When you complete the Save As dialog box, you can do any of the following:

Name a new hypergraphic.
Save an existing hypergraphic under a new name.
Save an existing hypergraphic under its original name.

The default extension .SHG is used if one is not specified.
See Also
Saving a Hypergraphic
Save Command



Exit Command
Closes any hypergraphics and exits Hotspot Editor.
If any hypergraphic is unsaved, Hotspot Editor lets you save it before exiting.



File Names
Opens a previously edited image file or hypergraphic. The last four hypergraphics opened 
or saved appear on the menu.
See Also
Opening Image Files and Hypergraphics



Edit Menu Commands
Choose the command you want help on.
Undo Command
Attributes Command
Select Command
Delete Command
Cut Commands
Copy Command
Paste Command
Replace Command
Preferences Command



Undo Command
Undoes your last edit.
You can undo:

Changes to hot spots, including changes to attributes, size and position
Deletions of hot spots (including cuts and deletes)
Insertions of hot spots



Attributes Command
Displays attributes for the selected hot spot. 
See Also
Attributes Dialog Box
Changing Hot Spot Attributes
Specifying Default Hot Spot Attributes



Select Command
Displays a dialog box listing all the defined hot spots for the hypergraphic and allows you to
select a hot spot by hot spot ID.
See Also
Creating a Tabbing Order
Changing the Tabbing Order
Select Dialog Box
Selecting Hot Spots



Delete Command
Deletes the selected hot spot.
See Also
Editing Hot Spots



Cut Command
Moves the selected hot spot to the Clipboard, replacing the previous Clipboard contents.
See Also
Copy Command
Cutting, Copying, and Pasting Hot Spots
Paste Command



Copy Command
Copies the selected hot spot to the Clipboard.
See Also
Cut Commands
Cutting, Copying, and Pasting Hot Spots
Paste Command



Paste Command
Pastes the contents of the Clipboard. 
If the Clipboard contains a graphic, Hotspot Editor creates a new hypergraphic and displays
it in a new window.
If the Clipboard contains a hot spot, the hot spot is pasted in the upper-left corner of the 
hypergraphic. (If a hot spot is selected, the Paste command is unavailable.)
See Also
Copy Command
Cut Commands
Cutting, Copying, and Pasting Hot Spots



Replace Command
Replaces the underlying bitmap in a hypergraphic without losing any hot spot information 
that has already been defined for the hypergraphic. 
See Also
Replacing the Bitmap in a Hypergraphic



Preferences Command
Displays a dialog box that lets you specify default hot spot attributes. Hotspot Editor 
automatically assigns these default attributes to new hot spots.
See Also
Attributes Command
Changing Hot Spot Attributes
Preferences Dialog Box
Specifying Default Hot Spot Attributes



Window Menu Commands
Choose the command you want help on.
Cascade Command
Tile Command
Arrange Icons Command
Document Window Names



Cascade Command
Arranges windows so they overlap, starting in the upper-left corner of the Hotspot Editor 
window.
The title bar of each window remains visible, making it easy to select any window.
See Also
Tile Command



Tile Command
Arranges the windows side by side, so each window is visible and no windows overlap.
See Also
Cascade Command



Arrange Icons Command
Arranges all icons in rows.



Window Names Command
Selects the window containing the specified hypergraphic.



Help Menu Commands
Choose the command you want help on.
Contents Command
About Command



Contents Command
Displays the Contents topic for the Hotspot Editor Help file.



About Command
Displays information about Hotspot Editor application, including copyright notice and 
version number.



Attributes Dialog Box
Changes the attributes for the selected hot spot. Click any control to get more information.

See Also
Changing Hot Spot Attributes
Attributes Command



Preferences Dialog Box
Changes default attribute settings. Click any control to get more information.

See Also
Specifying Default Hot Spot Attributes
Preferences Command



Select Dialog Box
Displays a list of hot spots for the hypergraphic. Click any control to get more information.

See Also
Selecting Hot Spots
Select Command



About Hotspot Editor
You use Hotspot Editor to create and edit hypergraphics. A hypergraphic is a bitmap that 
includes one or more hot spots. A hot spot can cover any portion of the bitmap. A bitmap 
can include multiple hot spots that link to Help topics or run Help macros when chosen.
Using Hotspot Editor, you can define hot spots for a bitmap and assign attributes to each 
hot spot. Each hot spot includes the following attributes:

Context string
Link type (jump, pop-up, macro, or searchable)
Visible or invisible hot spot borders
Hotspot ID

Hotspot Editor saves hypergraphics in a special compressed file format. Hypergraphic files 
generally have a .SHG filename extension.
See Also
Attributes Command
Changing Hot Spot Attributes
Specifying Default Hot Spot Attributes



Using Hypergraphics
To include a hypergraphic in a Help topic, use one of the standard bitmap reference codes 
(bmc, bml, or bmr). The hot spots on the hypergraphic work like standard hot spots in a 
topic file.
Hot spots must reference valid context strings for a Help project. The Help compiler 
displays a warning if the hot spot references a nonexistent context string.



Open
Opens 16-color bitmaps (.DIB or .BMP), metafiles (.WMF), or hypergraphics (.SHG).
When you open an image file, Hotspot Editor places the graphic in a new window. Other 
graphics that are open remain displayed in their own windows.
See Also
Opening Image Files and Hypergraphics
Open Command



Close
Closes the currently selected document window. If the hypergraphic is unsaved, Hotspot 
Editor lets you save it before closing the window.
See Also
Close Command



Save
Saves the current hypergraphic (the one displayed in the active window). Hotspot Editor 
displays a warning if you are overwriting the original hypergraphic.
When you choose Save, the hypergraphic remains open so you can continue working on it.
See Also
Save Command
Saving a Hypergraphic



Save As
Saves a hypergraphic.
When you complete the Save As dialog box, you can:

Name a new hypergraphic.
Save an existing hypergraphic under a new name.
Save an existing hypergraphic under its original name.

See Also
Save As Command
Saving a Hypergraphic



Exit
Closes any hypergraphics and exits Hotspot Editor.
If any hypergraphic is unsaved, Hotspot Editor lets you save it before exiting.
See Also
Exit Command



File Names
Opens a previously edited image file or hypergraphic. The last four hypergraphics opened 
or saved appear on the menu.
See Also
File Names
Opening Image Files and Hypergraphics



Undo
Undoes your last edit.
You can undo:

Changes to hot spots, including changes to attributes, size and position
Deletions of hot spots (including cuts and deletes)
Insertions of hot spots

See Also
Editing Hot Spots
Selecting Hot Spots
Undo Command



Attributes
Displays attributes for the selected hot spot. Click any control to get more information.

See Also
Attributes Command
Changing Hot Spot Attributes
Specifying Default Hot Spot Attributes



Select
Displays a dialog box listing all the defined hot spots for the hypergraphic and allows you to
select a hot spot by hot spot ID. Click any control to get more information.

See Also
Selecting Hot Spots
Select Command



Delete
Deletes the selected hot spot.
See Also
Editing Hot Spots
Delete Command



Cut
Moves the selected hot spot to the Clipboard, replacing the previous Clipboard contents.
See Also
Cut Command
Cutting, Copying, and Pasting Hot Spots



Copy
Copies the selected hot spot to the Clipboard, replacing the previous Clipboard contents.
See Also
Copy Command
Cutting, Copying, and Pasting Hot Spots



Paste
Pastes the contents of the Clipboard. 
If the Clipboard contains a graphic, Hotspot Editor creates a new hypergraphic and displays
it in a new window.
If the Clipboard contains a hot spot, the hot spot is pasted in the upper-left corner of the 
hypergraphic. (If a hot spot is selected, the Paste command is unavailable.)
See Also
Cutting, Copying, and Pasting Hot Spots
Opening Image Files and Hypergraphics
Paste Command



Replace
Replaces the underlying bitmap in a hypergraphic without losing any hot spot information 
that has already been defined for the hypergraphic. 
See Also
Replace Command
Replacing the Bitmap in a Hypergraphic



Preferences
Changes default attribute settings. Click any control to get more information.

See Also
Preferences Command
Specifying Default Hot Spot Attributes



Cascade
Arranges windows so they overlap, starting in the upper-left corner of the Hotspot Editor 
window.
The title bar of each window remains visible, making it easy to select any window.
See Also
Cascade Command



Tile
Arranges the windows side by side, so each window is visible and no windows overlap.
See Also
Tile Command



Arrange Icons
Arranges all icons in rows.
See Also
Arrange Icons Command



Window Names
Selects the window containing the specified hypergraphic.
See Also
Window Names



Attribute
Specifies a default border style (visible or invisible) for new hot spots.



Context String or Macro
The name and contents of this field depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Specifies a default context string for new hot spots. If you use standard 

context-string prefixes, you can use the prefix as the default context 
string.

Macro Specifies a default macro for new hot spots. When you create a hot spot, 
you can change the macro.

Searchable Specifies keywords for new hot spots. When you create a hot spot, you 
can add or change the associated keywords.



Hotspot ID
Specifies a default hotspot ID for new hot spots. When you create a new hot spot, Hotspot 
Editor appends a sequence number to this name and assigns the resulting ID to the new 
hot spot.



Type
Specifies a default hot spot type (jump, pop-up, macro, or searchable) for new hot spots.



Searchable
Specifies the default hot spot type searchable for new hot spots.



Macro
Specifies default hot spot type macro for new hot spots. 



Attribute
Specifies the hot spot border style (visible or invisible).



Bounding Box
Specifies rectangle coordinates for the hot spot.



Context String or Macro
The name and contents of this field depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Context String box. Specifies a context string for the hot spot.
Macro Macro box. Specifies a macro for the hot spot.
Searchable Searchable box. Specifies keywords for the hot spot.



Hotspot ID
Specifies an optional hot spot name. The hot spot ID helps you identify the hot spot and is 
displayed in the Select dialog box. The hot spot ID is optional.



Type
Specifies the type of link for the hot spot. A hot spot type can be jump, pop-up, macro, or 
searchable.



Attribute
Specifies the border style (visible or invisible) for the hot spot.



Context String or Macro
Specifies a Help topic context string or Help macro. The name and contents of this field 
depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Context String box. Specifies a context string for the hot spot.
Macro Macro box. Specifies a macro for the hot spot.
Searchable Searchable box. Specifies keywords for the hot spot.



Select
Closes the dialog box and selects the hot spot selected in the Hotspots box.



Type
Specifies the hot spot type (jump, pop-up, macro, or searchable) for the selected hot spot.



Hotspots
Displays the list of hotspot IDs for the hypergraphic. 
When you select a hotspot ID, the hot spot attributes are displayed.
You can select a hot spot by selecting a hotspot ID and then choosing the Select button.



OK
Closes the dialog box and saves any changes made.



Cancel
Closes the dialog box without saving any changes made.



Context String
Specifies a default context string for new hot spots. If you use standard context-string 
prefixes, you can use the prefix as the default context string. When you create a hot spot, 
you can add the suffix to complete the context string.
Context String is present if Type is jump or pop-up.
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Macro
Specifies a default macro for new hot spots. When you create a hot spot, you can change 
the macro.
Macro is present if Type is Macro.
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Searchable
Specifies the default searchables for new hot spots. When you create a hot spot, you can 
edit the searchable hot spots.
Searchable is present if Type is Searchable. 
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Type
Specifies a default hot spot type (jump, pop-up, macro, or searchable) for new hot spots.
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Attribute
Specifies a default border style (visible or invisible) for new hot spots.
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Hotspot ID
Specifies a default hot spot name for new hot spots. The hotspot ID can help you identify 
the hot spot. Hotspot Editor appends a sequence number to this name and assigns the 
resulting ID to the new hot spot.
See Also
Specifying Default Hot Spot Attributes
Preferences Dialog Box



Context String
Specifies the context string of the Help topic to display when the user clicks the hot spot.
Context String is present if Type is jump or pop-up.
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Macro
Specifies the Help macro to run when the user clicks the hot spot.
Macro is present if Type is Macro.
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Searchables
Specifies searchablewords to associate with the hypergraphic.
Searchable is present if Type is Searchable.
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Type
Specifies the hot spot type (jump, pop-up, macro, or searchable).
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Attribute
Specifies the hot spot border style (visible or invisible).
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Hotspot ID
Specifies an optional hot spot name. The hotspot ID helps you identify the hot spot and is 
displayed in the Select dialog box. 
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Bounding Box
Specifies rectangle coordinates for the hot spot.
See Also
Changing Hot Spot Attributes
Attributes Dialog Box



Hotspots
Displays the list of hotspot IDs for the hypergraphic. 
When you select a hotspot ID, the hot spot attributes are displayed.
You can select a hot spot by selecting a hotspot ID and then choosing the Select button.
See Also
Selecting Hot Spots
Select Dialog Box





hot spot
A rectangular region on a hypergraphic that has an associated action. When the user 
chooses the hot spot, Help performs an action, depending on the hot spot type: jump link, 
pop-up link, macro, or searchable. 



hypergraphic
A bitmap that includes one or more hot spots.



hotspot ID
An optional name for a hot spot. The author can use this name to identify a particular hot 
spot within the hypergraphic.



context string
A unique identifier for a Help topic. Help identifies each Help topic by its context string.



pop-up hot spot
A hot spot that creates a link to another Help topic. When the user chooses a pop-up hot 
spot, Help displays a pop-up window containing the Help topic with the specified context 
string. 



jump hot spot
A hot spot that creates a link to another Help topic. When the user chooses a jump hot 
spot, Help replaces the currently displayed topic with the Help topic with the specified 
context string. 



macro hot spot
A hot spot that runs a special Help procedure. A macro can include standard Help functions 
and calls to functions defined in dynamic-link libraries registered with your Help project.
When the user selects a hot spot associated with a macro, Help runs the macro.



searchable hot spot
A hot spot that defines Search keywords for the hypergraphic. When users choose the 
Search button, these keywords can help them locate pictures in the Help file.





Opening Image Files and Hypergraphics
To add hot spots to a bitmap with Hotspot Editor, you first create an image file and then 
open it in Hotspot Editor. You can create a hypergraphic in two ways:

By opening an existing bitmap file (.BMP or .DIB) or metafile (.WMF) and saving it 
in .SHG format

By pasting a bitmap or metafile from the Clipboard and saving it in .SHG format
To edit more than one image file at a time, open multiple files. Each file appears in its own 
document window in Hotspot Editor.
To open a new bitmap file
1 From the File menu, choose Open.

The Open dialog box appears.
2 If the file is in the current directory, select the name of the file in the Files box.

If the file is not in the current directory, double-click the directory you want in the 
Directories box, and then select the name of the file in the Files box.
Hotspot Editor displays in the Files box only those files whose extensions match the 
supported file formats.
Instead of using the Files and Directories boxes to open a file, you can type the complete 
path in the File Name box.

3 Choose OK.
Hotspot Editor opens the bitmap and displays it in a new window.

To paste a bitmap or metafile from the Clipboard
1 Place the bitmap file on the Clipboard.
2 From the Edit menu, choose Paste.

Hotspot Editor opens the bitmap and displays it in a new window.

Hotspot Editor records the last four files you opened. Their paths and filenames are 
displayed at the bottom of the File menu in Hotspot Editor.
You can open a previously edited file in two ways: either choose the file you want to open 
from the File menu or type the number that appears to the left of the file you want to open.
To open a previously edited hypergraphic

From the File menu, choose the name of the hypergraphic you want to open.
See Also
Creating Hot Spots
Open Command
Paste Command



Specifying Default Hot Spot Attributes
Hotspot Editor lets you specify default values for hot spot attributes. When you create a 
new hot spot, these values are automatically assigned to the new hot spot. After creating a 
hot spot, you can change the attributes.
To assign default hot spot attributes
1 From the Edit menu, choose Preferences.
2 Enter the default hot spot attributes.
3 Choose OK.
You can specify the following default attributes
Attribute Description
Context string Specifies a default context string for new hot spots. If your Help project uses 

standard context-string prefixes, you can use the prefix as the default context string.
Type Specifies a default hot spot type (jump, pop-up, macro, or searchable) for new hot 

spots.
Attribute Specifies a default border style (visible or invisible) for new hot spots. 
Hotspot ID Specifies a default hot spot ID for new hot spots. When you create a new hot spot, 

Hotspot Editor appends a sequence number to this name.

See Also
Attributes Dialog Box
Changing Hot Spot Attributes
Preferences Command
Preferences Dialog Box



Creating Hot Spots
After opening an image file in Hotspot Editor, you create hot spots. For each hot-spot, you 
follow the same steps.
To create a new hot spot
1 Draw a hot spot rectangle across the image with the left mouse button pressed.

A selection cursor appears marking the hot spot boundaries.
2 Define attributes for the hot spot.

This determines what happens when users choose the hot spot.
To create a hot spot and display hot spot attributes

With the right mouse button pressed, drag across the image.
A selection cursor appears marking the hot spot boundaries. 
When you release the right mouse button, the Attributes dialog box appears.

You can draw hot spots so that they overlap each other; however, in the built Help file, only 
the top most hot spot is active in a stack of overlapped hot spots.
See Also
Attributes Dialog Box
Changing Hot Spot Attributes
Editing Hot Spots
Selecting Hot Spots



Creating a Tabbing Order
In the built Help file, users can select the hot spots either with the mouse or with the 
keyboard. When using a keyboard, users press the TAB key to move from one hot spot to the
next. This is called the tabbing order. 
Hotspot Editor creates the tabbing order in the same order that you create the hot spots 
within the graphic.
To create a specific tabbing order

Define each hot spot in the same order you want users to follow in the built Help file.
After you have created one or more hot spots, you can view the tabbing order by using the 
Select command on the Edit menu.
To view the tabbing order in a hypergraphic

From the Edit menu, choose Select.
The Select dialog box appears, listing all the defined hot-spots in the hypergraphic. The hot 
spots are displayed in the order in which they were created, with the first hot spot at the 
top of the list box.
See Also
Changing the Tabbing Order



Changing the Tabbing Order
If you have already created hot spots in a hypergraphic, and later you want to change the 
tabbing order, you can use commands on the Edit menu to do so.
To change the tabbing order
1 From the Edit menu, choose Select.

The Select dialog box appears with the hot spots listed in the current tabbing order.
2 Select the hot spot that you want to move to the top of the tabbing order.
3 Choose the Select button.

The hot-spot rectangle displays eight sizing handles, indicating that it is the currently 
selected hot spot.

4 From the Edit menu, choose Delete.
Or press the DEL key.
The hot spot is deleted.

5 From the Edit menu, choose Undo.
The hot spot is restored to the hypergraphic, and it is moved to the top of the tabbing 
order. To view the new tabbing order, use the Select command.

6 From the Edit menu, choose Select to view the new tabbing order.
The selected hot spot is at the top of the tabbing order.
Note:    If you did not assign unique identifiers to each hot spot, it may be impossible to 
tell that the tabbing order has changed.

7 Repeat steps 1-5 to move another hot spot.

See Also
Creating a Tabbing Order



Selecting Hot Spots
Hotspot Editor displays the attributes of the selected hot spot in the status area at the 
bottom of the main window. You can click on the following status-area hypergraphic to get 
an explanation of the fields:

The border of the selected hot spot includes sizing handles.
To select a hot spot

Click the hot spot.
If the hot spot is enclosed in another hot spot, you won't be able to select the inside hot 
spot if the outermost hot spot is selected. Remove the selection from the outermost hot 
spot first (click outside the outermost hot spot).
To select a hot spot and display the attributes

Double-click the hot spot.
Or, with the right mouse button, click the hot spot.

If the hot spot is enclosed in another hot spot, you won't be able to select the inside hot 
spot if the outermost hot spot is selected. Remove the selection from the outermost hot 
spot first (click outside the outermost hot spot).
To select a hot spot using the keyboard

Press TAB.
The selection moves to the next hot spot.

To select a hot spot using the Select command
1 From the Edit menu, choose Select.

The Select dialog box appears. All hot spots defined for the hypergraphic appear in the 
Hotspots box. By default, Hotspot Editor does not select a hot spot in the list unless one 
was selected before choosing the Select command. In that case, Hotspot Editor 
highlights the currently selected hot spot.

2 In the Hotspots box, select a hot-spot name.
3 Choose the Select button.

The hot spot shows eight sizing handles to indicate that the hot spot is selected.

See Also
Attributes Dialog Box
Changing Hot Spot Attributes
Select Command
Select Dialog Box



Editing Hot Spots

To resize a hot spot
1 Select the hot spot.

Handles appear on the sides and corners of the hot spot.
2 Drag a side handle to move one side of the rectangle.

Or, drag a corner handle to move two sides of the rectangle. 
To resize or position a hot spot using the keyboard
1 Select the hot spot.
2 Press ENTER.
3 Change the Bounding Box values on the Attributes dialog box.
4 Choose OK.
To move a hot spot
1 Select the hot spot.
2 Drag the center of the hot spot to the desired location. 
To delete a hot spot
1 Select the hot spot.
2 From the Edit menu, choose Delete.

Or, press the DEL key.

See Also
Attributes Dialog Box
Delete Command
Select Command
Selecting a Hot Spot



Cutting, Copying, and Pasting Hot Spots
Use the Cut, Copy, and Paste commands on the Edit menu to transfer hot spots to the 
Clipboard. Transferring hot spots is useful to:

Create multiple versions of the same hot spot with the same attributes.
Move a hot spot from one image file to another.
Save time when repeatedly defining hot spots in a hypergraphic.

To cut or copy a hot spot to the Clipboard
1 Select the hot spot.
2 From the Edit menu, choose Cut or Copy.

Hotspot Editor transfers the selected hot spot to the Clipboard using Hotspot Editors 
proprietary clipboard format.

You can paste images or hot spots from the Clipboard into Hotspot Editor. Pasting an image 
is the same as opening the file. If you paste a hot spot, Hotspot Editor pastes it in the 
upper-left corner. You can paste a hot spot into the same image file or another image file.
To paste a hot spot

From the Edit menu, choose Paste.
The hot spot is pasted in the upper-left corner of the hypergraphic being edited.

See Also
Copy Command
Cut Commands
Paste Command



Replacing the Bitmap in a Hypergraphic
Because Hotspot Editor does not alter the original bitmap or metafile when creating a 
hypergraphic, you can edit the original bitmap (.BMP) or metafile (.WMF) in the graphics 
program and then re-import it into Hotspot Editor after you have made your changes.
To replace the bitmap in a hypergraphic
1 Open the original bitmap or metafile in the graphics application you used to create the 

image.
Or create a new bitmap for the hypergraphic.

2 Make your changes to the image.
3 Save the edited image in the graphics application.
4 Copy the image to the Clipboard.
5 Start Hotspot Editor and open the hypergraphic that contains the graphic you want to 

replace.
6 From the Edit menu, choose Replace. 

The new or edited graphic replaces the original bitmap.
Note:    If the new image is smaller than the original graphic included in the hypergraphic,
Hotspot Editor may move the hot spots to ensure that they are still on top of the image.

7 Save the changes to the hypergraphic. 

See Also
Replace Command



Changing Hot Spot Attributes
Hotspot Editor displays the attributes of the selected hot spot in the status area at the 
bottom of the main window. You can also display the Attributes dialog box for a hot spot; 
this displays the hot spot attributes and allows you to change the attributes.
To change hot spot attributes
1 Double-click the hot spot.

Or, with the right mouse button, click the hot spot. 
2 Enter the attribute values.
3 Choose OK.
The attributes are as follows:
Attribute Description
Context string Specifies the context string of the linked Help topic. Context string is 

present when Type is Jump or Pop-Up.
Macro Specifies a help macro. Macro is present when Type is Macro.
Type Specifies the hot spot type (jump, pop-up, macro, or searchable).
Attribute Specifies the hot spot border style (visible or invisible).
Hotspot ID Specifies an optional hot spot name. This allows you to identify the hot 

spot and is displayed in the Select dialog box.
Bounding box Specifies rectangle coordinates for the hot spot.
See Also
Attributes Command
Attributes Dialog Box
Selecting a Hot Spot



Saving a Hypergraphic
After you have defined all the hot spots and made all your changes to the image, you save 
it as a hypergraphic.
To save a hypergraphic
1 From the File menu, choose Save As.
2 Enter a filename for the new hypergraphic.
3 Choose OK.

Hotspot Editor saves the hypergraphic in .SHG format.

See Also
Save As Command
Save Command





Hotspot Editor Keys
Use the following keys in Hotspot Editor.
Press Function
F1 Displays Help.
ALT+BACKSPACE Undoes the last edit.
DEL Deletes the selected hot spot.
SHIFT+DEL Moves the selected hot spot to the Clipboard.
CTRL+INS Copies the selected hot spot to the Clipboard.
SHIFT+INS Inserts the Clipboard contents. 

If the Clipboard contains a graphic, creates a new hypergraphic. 
If the Clipboard contains a hot spot, inserts the hot spot at the upper-left 
corner of the current window.

TAB Selects the next hot spot.
ENTER Displays the Attributes dialog box for the selected hot spot.
SHIFT+F5 Cascades the open windows.
SHIFT+F4 Tiles the open windows.




